Click or drag to resize

GH_LooseChunk Class

A utility class for creating partial archives.
Inheritance Hierarchy

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public class GH_LooseChunk : GH_Chunk

The GH_LooseChunk type exposes the following members.

Constructors
  NameDescription
Public methodGH_LooseChunk(String)
Create a new loose chunk. A loose chunk does not have an owner archive and thus cannot store runtime messages.
Public methodGH_LooseChunk(String, Int32)
Create a new loose chunk. A loose chunk does not have an owner archive and thus cannot store runtime messages.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Public methodDeserialize_Binary
Deserializes a byte array.
Public methodDeserialize_Xml
Deserializes an Xml string.
Public methodCode exampleSerialize_Binary
Serializes the data tree into a byte array.
Public methodCode exampleSerialize_Xml
Serializes the data tree into an Xml string.
Top
Fields
  NameDescription
Top
See Also