Click or drag to resize

GH_Message Class

Represents an archive log message. Messages are collected during read/write operations.
Inheritance Hierarchy
SystemObject
  GH_IO.SerializationGH_Message

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public class GH_Message

The GH_Message type exposes the following members.

Constructors
  NameDescription
Public methodGH_Message
Fake constructor to avoid new instances being created by a PropertyGrid.
Public methodGH_Message(String)
Create a new message of type GH_Message_Type.info
Public methodGH_Message(String, GH_Message_Type)
Create a new message.
Top
Properties
  NameDescription
Public propertyMessage
Gets the text content of this message.
Public propertyType
Gets the type of this message.
Top
See Also