Click or drag to resize

GH_Item Class

Represents a single data item in a chunk.
Inheritance Hierarchy
SystemObject
  GH_IO.TypesGH_Item

Namespace:  GH_IO.Types
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public class GH_Item : GH_IBinarySupport, GH_IXmlSupport

The GH_Item type exposes the following members.

Constructors
  NameDescription
Public methodGH_Item(String, GH_BoundingBox)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Interval1D)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Interval2D)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Line)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Plane)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Point2D)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Point3D)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Point4D)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, GH_Version)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Boolean)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Byte)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Byte)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, DateTime)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Decimal)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Double)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Double)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Bitmap)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Color)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Point)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, PointF)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Rectangle)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, RectangleF)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Size)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, SizeF)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Guid)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Int32)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Int64)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Single)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, String)
Construct a new instance of GH_Item with the specified name and value.
Public methodGH_Item(String, Int32, GH_BoundingBox)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Interval1D)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Interval2D)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Line)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Plane)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Point2D)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Point3D)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Point4D)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, GH_Version)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Boolean)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Byte)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Byte)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, DateTime)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Decimal)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Double)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Double)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Bitmap)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Color)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Point)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, PointF)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Rectangle)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, RectangleF)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Size)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, SizeF)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Guid)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Int32)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Int64)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, Single)
Construct a new instance of GH_Item with the specified name, index and value.
Public methodGH_Item(String, Int32, String)
Construct a new instance of GH_Item with the specified name, index and value.
Top
Properties
  NameDescription
Public property_bool
Returns the internal data of this item cast to a Boolean. If the data is not stored as a Boolean, a conversion exception might be thrown.
Public property_boundingbox
Returns the internal data of this item cast to a BoundingBox. If the data is not stored as a BoundingBox, a conversion exception might be thrown.
Public property_byte
Returns the internal data of this item cast to a Byte. If the data is not stored as a Byte, a conversion exception might be thrown.
Public property_bytearray
Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.
Public property_date
Returns the internal data of this item cast to a DateTime. If the data is not stored as a DateTime, a conversion exception might be thrown.
Public property_decimal
Returns the internal data of this item cast to a Decimal. If the data is not stored as a Decimal, a conversion exception might be thrown.
Public property_double
Returns the internal data of this item cast to a Double. If the data is not stored as a Double, a conversion exception might be thrown.
Public property_doublearray
Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.
Public property_drawing_bitmap
Returns the internal data of this item cast to a Bitmap. If the data is not stored as a Bitmap, a conversion exception might be thrown.
Public property_drawing_color
Returns the internal data of this item cast to a Color. If the data is not stored as a Color, a conversion exception might be thrown.
Public property_drawing_point
Returns the internal data of this item cast to a Point. If the data is not stored as a Point, a conversion exception might be thrown.
Public property_drawing_pointf
Returns the internal data of this item cast to a PointF. If the data is not stored as a PointF, a conversion exception might be thrown.
Public property_drawing_rectangle
Returns the internal data of this item cast to a Rectangle. If the data is not stored as a Rectangle, a conversion exception might be thrown.
Public property_drawing_rectanglef
Returns the internal data of this item cast to a RectangleF. If the data is not stored as a RectangleF, a conversion exception might be thrown.
Public property_drawing_size
Returns the internal data of this item cast to a Size. If the data is not stored as a Size, a conversion exception might be thrown.
Public property_drawing_sizef
Returns the internal data of this item cast to a SizeF. If the data is not stored as a SizeF, a conversion exception might be thrown.
Public property_guid
Returns the internal data of this item cast to a Guid. If the data is not stored as a Guid, a conversion exception might be thrown.
Public property_int32
Returns the internal data of this item cast to an Int32. If the data is not stored as an Int32, a conversion exception might be thrown.
Public property_int64
Returns the internal data of this item cast to an Int64. If the data is not stored as an Int64, a conversion exception might be thrown.
Public property_interval1d
Returns the internal data of this item cast to an Interval1D. If the data is not stored as an Interval1D, a conversion exception might be thrown.
Public property_interval2d
Returns the internal data of this item cast to an Interval2D. If the data is not stored as an Interval2D, a conversion exception might be thrown.
Public property_line
Returns the internal data of this item cast to a Line. If the data is not stored as a Line, a conversion exception might be thrown.
Public property_plane
Returns the internal data of this item cast to a Plane. If the data is not stored as a Plane, a conversion exception might be thrown.
Public property_point2d
Returns the internal data of this item cast to a Point2D. If the data is not stored as a Point2D, a conversion exception might be thrown.
Public property_point3d
Returns the internal data of this item cast to a Point3D. If the data is not stored as a Point3D, a conversion exception might be thrown.
Public property_point4d
Returns the internal data of this item cast to a Point4D. If the data is not stored as a Point4D, a conversion exception might be thrown.
Public property_single
Returns the internal data of this item cast to a Single. If the data is not stored as a Single, a conversion exception might be thrown.
Public property_string
Returns the internal data of this item cast to a String. If the data is not stored as a String, a conversion exception might be thrown.
Public property_version
Returns the internal data of this item cast to a Version. If the data is not stored as a Version, a conversion exception might be thrown.
Public propertyHasIndex
Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.
Public propertyHasName
Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)
Public propertyHasType
Gets the type set validity of this item. The item is considered to have a type if type != GH_Types.unset
Public propertyIndex
Gets or sets the index of an item. Typically, indices are set at construction and do not change. If you change indices after construction, you could corrupt an archive.
Public propertyInternalData
Retrieves the internal data of this item. No type casting is performed.
Public propertyName
Gets or sets the name of this item. Typically, names are set at construction and do not change. If you change names after construction, you could corrupt an archive.
Public propertyType
Gets the type of this item. Type flags are set during construction and cannot be altered.
Top
Methods
  NameDescription
Public methodStatic memberCreateFrom(BinaryReader)
Creates a new instance of GH_Item and sets the fields from a reader object.
Public methodStatic memberCreateFrom(XmlNode)
Creates a new instance of GH_Item and sets the fields from an Xml node object.
Public methodRead(BinaryReader)
Deserialize this item from a binary stream.
Public methodRead(XmlNode)
Deserialize this item from an Xml node.
Public methodToString
Converts the struct into a human readable format.
(Overrides ObjectToString.)
Public methodWrite(BinaryWriter)
Serialize this item into a binary stream.
Public methodWrite(XmlWriter)
Serialize this item into an Xml stream.
Top
See Also