Click or drag to resize

GH_ColourPickerEventArgs Class

Arguments passed via GH_SliderBase.ValueChanged events.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.GUI.BaseGH_ColourPickerEventArgs

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ColourPickerEventArgs : EventArgs

The GH_ColourPickerEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyColour
Gets the new value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.
Public propertyColourPicker
Gets the instance of the picker that raised the event.
Public propertyIntermediate
Gets a value indicating whether the change was an intermediate one.
Public propertyOriginal
Gets the original value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.
Top
See Also