Click or drag to resize

GH_DigitNumber Class

Maintains and provides functionality for evaluating and modifying numbers as used in the GH_DigitScrollerBase control.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.BaseGH_DigitNumber

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DigitNumber

The GH_DigitNumber type exposes the following members.

Constructors
  NameDescription
Public methodGH_DigitNumber(GH_DigitNumber)
Create an exact duplicate of another GH_DigitNumber instance.
Public methodGH_DigitNumber(Int32)
Create a new GH_DigitNumber instance with the specified number of decimal places.
Public methodGH_DigitNumber(Int32, Int32)
Create a new GH_DigitNumber instance with the specified number of decimal places and a given radix position.
Top
Properties
  NameDescription
Public propertyDigitCount
Gets or sets the amount of digits in this number.
Public propertyEpsilon
Gets the smallest possible change.
Public propertyIsPrimaryDigitSignificant
Gets whether the primary digit at the given index is significant.
Public propertyIsSecondaryDigitSignificant
Gets whether the secondary digit at the given index is significant.
Public propertyMaximum
Gets the maximum value allowed in this number.
Public propertyMinimum
Gets the minimum value allowed in this number.
Public propertyOffset
Gets the offset between the primary and secondary digits.
Public propertyPrimaryDigits
Gets the internal list of primary digits. Do not modify this list.
Public propertyPrimaryPositive
Gets or sets a value indicating whether the number is positive.
Public propertyRadix
Gets or sets the radix point index. A negative radix index disables the radix point, zero is not a valid index.
Public propertyRadixIndex
Gets the mapped radix.
Public propertySecondaryDigits
Gets the internal list of secondary digits. Do not modify this list.
Public propertySecondaryPositive
Gets a value indicating whether the secondary number is positive.
Public propertyValue
Gets or sets the value of this number.
Top
Methods
  NameDescription
Public methodAssignOffset
Assign an offset to a given digit and recursively adjust all leftwards offsets if needed.
Public methodLimitValue
Limits the value to the minimum and maximum domain.
Public methodReset
Reset all parts to zero.
Public methodRound
Round the number by cancelling the offset in the proper direction.
Public methodToString (Overrides ObjectToString.)
Top
See Also