Click or drag to resize

GH_SliderEventArgs Class

Arguments passed via GH_SliderBase.ValueChanged events.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.GUI.BaseGH_SliderEventArgs

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_SliderEventArgs : EventArgs

The GH_SliderEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyIntermediate
Gets a value indicating whether the change was an intermediate one.
Public propertySlider
Gets the instance of the slider that raised the event.
Public propertyValue
Gets the new value of the slider. This value is cached, so even if the slider subsequently updates, this property remains constant.
Top
See Also