Click or drag to resize

GH_TextBoxInputBase Class

Inheritance Hierarchy

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_TextBoxInputBase

The GH_TextBoxInputBase type exposes the following members.

Constructors
  NameDescription
Protected methodGH_TextBoxInputBase
Initializes a new instance of the GH_TextBoxInputBase class
Top
Properties
  NameDescription
Public propertyFont
Gets or sets the Font to use in this control.
Public propertyIsTextInput
Gets whether the text input box is currently on screen.
Top
Methods
  NameDescription
Protected methodHandleTextInputAccepted
Public methodHideTextInputBox
Hides the text-input override form (if it is displayed).
Public methodRespondToEnter
Public methodRespondToEscape
Public methodShowTextInputBox(Control, String, Boolean)
Display a floating text-box on top of the owner control.
Public methodShowTextInputBox(Control, String, Boolean, Boolean)
Display a floating text-box on top of the owner control.
Public methodShowTextInputBox(Control, String, Boolean, Boolean, Matrix)
Display a floating text-box on top of the owner control.
Top
See Also