Click or drag to resize

GH_CanvasChannel Enumeration

Enumerates all the drawing channels that are handled inside the Grasshopper canvas.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_CanvasChannel
Members
  Member nameValueDescription
First0 First channel. At present, the first channel equals the Groups channel.
Groups0 Channel for Group outlines and name tags.
Wires10 Channel for connecting wires.
Objects20 Channels for Document Objects (components, parameters, special objects)
Overlay30 Channel for drawing overlay geometry.
Last30 Last channel. At present, the last channel equals the Overlay channel.
See Also