Click or drag to resize

GH_CanvasValidator Class

Abstract implementation of IGH_CanvasValidator. Inherit from this class rather than implementing IGH_CanvasValidator from scratch.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_CanvasValidator : IGH_CanvasValidator

The GH_CanvasValidator type exposes the following members.

Constructors
  NameDescription
Protected methodGH_CanvasValidator
Initializes a new instance of the GH_CanvasValidator class
Top
Properties
  NameDescription
Protected propertyCanvas
Gets the canvas this validator is associated with.
Protected propertyDocument
Gets the document (if it exists) that is currently loaded in the canvas.
Top
Methods
  NameDescription
Public methodAddedToCanvas
Override this method if you want to be informed when this validator gets assigned to a canvas. But *always* call the base class method.
Public methodAppliesToDocument
Public methodCanAcceptObject
Public methodCanCreateObject
Public methodCanCreateWire
Public methodCanDeleteObject
Public methodCanDeleteWire
Public methodCanDragObject
Public methodCanNavigateCanvas
Public methodCanShowCanvasMenu
Public methodCanShowComponentSearchBox
Public methodCanShowObjectMenu
Public methodRemovedFromCanvas
Override this method if you want to be informed when this validator gets removed from a canvas. But *always* call the base class method.
Top
See Also