Click or drag to resize

GH_CanvasWireValidator Class

Utility validator for restricting wire creation.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_CanvasWireValidator : GH_CanvasValidator

The GH_CanvasWireValidator type exposes the following members.

Constructors
  NameDescription
Public methodGH_CanvasWireValidator
Initializes a new instance of the GH_CanvasWireValidator class
Top
Properties
  NameDescription
Public propertyWireDelegate
Gets or sets the delegate to be invoked when a wire is created.
Public propertyWireMotionText
Gets or sets the text to draw at the wire interior.
Public propertyWireSource
Gets or sets the wire source filter.
Public propertyWireSourceText
Gets or sets the text to draw at the wire source location.
Public propertyWireTarget
Gets or sets the wire target filter.
Public propertyWireTargetText
Gets or sets the text to draw at the wire target location.
Top
Methods
  NameDescription
Public methodAddedToCanvas (Overrides GH_CanvasValidatorAddedToCanvas(GH_Canvas).)
Public methodAppliesToDocument (Overrides GH_CanvasValidatorAppliesToDocument(Guid).)
Public methodCanAcceptObject (Overrides GH_CanvasValidatorCanAcceptObject(Guid).)
Public methodCanCreateObject (Overrides GH_CanvasValidatorCanCreateObject(Guid, PointF).)
Public methodCanCreateWire (Overrides GH_CanvasValidatorCanCreateWire(IGH_Param, IGH_Param).)
Public methodCanDeleteObject (Overrides GH_CanvasValidatorCanDeleteObject(IGH_DocumentObject).)
Public methodCanDeleteWire (Overrides GH_CanvasValidatorCanDeleteWire(IGH_Param, IGH_Param).)
Public methodCanDragObject (Overrides GH_CanvasValidatorCanDragObject(IGH_DocumentObject, PointF).)
Public methodCanShowCanvasMenu (Overrides GH_CanvasValidatorCanShowCanvasMenu(PointF).)
Public methodCanShowComponentSearchBox (Overrides GH_CanvasValidatorCanShowComponentSearchBox(PointF).)
Public methodRemovedFromCanvas (Overrides GH_CanvasValidatorRemovedFromCanvas(GH_Canvas).)
Top
See Also