Click or drag to resize

GH_CapsuleRenderEngine Class

Provides basic Render methods for capsule display. You typically don't need this class, just use the Render() overloads on GH_Capsule directly.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.CanvasGH_CapsuleRenderEngine

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_CapsuleRenderEngine

The GH_CapsuleRenderEngine type exposes the following members.

Methods
  NameDescription
Public methodStatic memberCreateHighlightBar(Rectangle, Int32, Int32)
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
Public methodStatic memberCreateHighlightBar(Rectangle, Int32, Int32, Int32)
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
Public methodStatic memberCreateHighlightBar(Rectangle, Int32, Int32, Boolean, Boolean)
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
Public methodStatic memberCreateHighlightBar(Rectangle, Int32, Int32, Int32, Boolean, Boolean)
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
Public methodStatic memberCreateJaggedRectangle
Static (Shared in VB) method for creating rectangles with rounded corners.
Public methodStatic memberCreateRoundedRectangle(Rectangle, Int32)
Static (Shared in VB) method for creating rectangles with rounded corners.
Public methodStatic memberCreateRoundedRectangle(RectangleF, Single)
Static (Shared in VB) method for creating rectangles with rounded corners.
Public methodStatic memberCreateRoundedRectangle(Rectangle, Int32, Int32, Int32, Int32)
Static (Shared in VB) method for creating rectangles with rounded corners.
Public methodStatic memberCreateRoundedRectangle(RectangleF, Single, Single, Single, Single)
Static (Shared in VB) method for creating rectangles with rounded corners.
Public methodStatic memberGetImpliedPalette
Static (Shared in VB) method for solving which palette is the default given a specific object's properties. Default palettes are either GH_Palette.Normal, GH_Palette.Warning or GH_Palette.Error depending on the objects' runtime message level.
Public methodStatic memberGetImpliedStyle(GH_Palette, IGH_Attributes)
Static (Shared in VB) method for solving which palette style is implied by the properties.
Public methodStatic memberGetImpliedStyle(GH_Palette, Boolean, Boolean, Boolean)
Static (Shared in VB) method for solving which palette style is implied by the properties.
Public methodRenderAlphaFill
Render a standard transparancy background hatch. This is only needed when the capsule background colour is not fully opaque. This is usually the second stage in a capsule rendering, right after the Grips are drawn.
Public methodRenderBackground
Render a default capsule background fill. This is usually the third stage in a capsule rendering.
Public methodRenderBackground_Alternative
Render a custom capsule background fill. This is usually the third stage in a capsule rendering.
Public methodRenderBoundaryDots
Render a collection of boundary dots along the top edge of the capsule.
Public methodRenderGrips
Render all the grips associates with the capsule. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.
Public methodRenderGrips_Alternative
Render all the grips associates with the capsule as semi-circles. This is needed if the capsule background is not fully opaque. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.
Public methodRenderHighlight
Render a highlight bar. This is highly zoom-dependant. Highlight rendering is usually the fourth stage in a Capsule Rendering, after the background but prior to the edges.
Public methodRenderIcon(Graphics, Image, Int32, Int32)
Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.
Public methodRenderIcon(Graphics, Image, RectangleF, Int32, Int32)
Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.
Public methodStatic memberRenderInputGrip
Static (Shared in VB) method to render a default input grip.
Public methodRenderMessage
Render a text message underneath the capsule.
Public methodRenderOutlines
Render default capsule outlines. If the zoom factor is less than 50% the inner outline is not drawn. This is usually the fifth stage in a Capsule rendering.
Public methodStatic memberRenderOutputGrip
Static (Shared in VB) method to render a default output grip.
Public methodRenderText
Render the capsule text. This is usually the sixth and final stage in a capsule rendering.
Top
See Also