Click or drag to resize

IGH_TooltipAwareObject Interface

Implement this interface if you want your object to participate in Grasshopper Canvas tooltips.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_TooltipAwareObject

The IGH_TooltipAwareObject type exposes the following members.

Properties
  NameDescription
Public propertyTooltipEnabled
Gets the tooltip enabled value. If False, no further tooltip functions will be called.
Top
Methods
  NameDescription
Public methodIsTooltipRegion
Determine whether the specified pixel should result in a tooltip when the cursor hovers over it.
Public methodSetupTooltip
This function is called when a tooltip it about to be displayed.
Top
See Also