Click or drag to resize

GH_Animator Class

Provides static methods and constructors GH_Animator(Of T).
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_Animator

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_Animator

The GH_Animator type exposes the following members.

Methods
  NameDescription
Public methodStatic memberDecimalAnimator(Decimal, Decimal)
Public methodStatic memberDecimalAnimator(Decimal, Decimal, Int32)
Public methodStatic memberDecimalAnimator(Decimal, Decimal, DateTime, DateTime)
Public methodStatic memberDoubleAnimator(Double, Double)
Public methodStatic memberDoubleAnimator(Double, Double, Int32)
Public methodStatic memberDoubleAnimator(Double, Double, DateTime, DateTime)
Public methodStatic memberIntegerAnimator(Int32, Int32)
Public methodStatic memberIntegerAnimator(Int32, Int32, Int32)
Public methodStatic memberIntegerAnimator(Int32, Int32, DateTime, DateTime)
Public methodStatic memberInterpolateDecimal
Utility interpolation delegate for System.Decimal values.
Public methodStatic memberInterpolateDouble
Utility interpolation delegate for System.Double values.
Public methodStatic memberInterpolateInteger
Utility interpolation delegate for System.Int32 values.
Public methodStatic memberInterpolatePoint
Utility interpolation delegate for System.Drawing.Point values.
Public methodStatic memberInterpolatePointF
Utility interpolation delegate for System.Drawing.PointF values.
Public methodStatic memberInterpolateRectangle
Utility interpolation delegate for System.Drawing.Rectangle values.
Public methodStatic memberInterpolateRectangleF
Utility interpolation delegate for System.Drawing.RectangleF values.
Public methodStatic memberInterpolateSingle
Utility interpolation delegate for System.Single values.
Public methodStatic memberPointAnimator(Point, Point)
Public methodStatic memberPointAnimator(Point, Point, Int32)
Public methodStatic memberPointAnimator(Point, Point, DateTime, DateTime)
Public methodStatic memberPointFAnimator(PointF, PointF)
Public methodStatic memberPointFAnimator(PointF, PointF, Int32)
Public methodStatic memberPointFAnimator(PointF, PointF, DateTime, DateTime)
Public methodStatic memberRectangleAnimator(Rectangle, Rectangle)
Public methodStatic memberRectangleAnimator(Rectangle, Rectangle, Int32)
Public methodStatic memberRectangleAnimator(Rectangle, Rectangle, DateTime, DateTime)
Public methodStatic memberRectangleFAnimator(RectangleF, RectangleF)
Public methodStatic memberRectangleFAnimator(RectangleF, RectangleF, Int32)
Public methodStatic memberRectangleFAnimator(RectangleF, RectangleF, DateTime, DateTime)
Public methodStatic memberSingleAnimator(Single, Single)
Public methodStatic memberSingleAnimator(Single, Single, Int32)
Public methodStatic memberSingleAnimator(Single, Single, DateTime, DateTime)
Top
See Also