Click or drag to resize

GH_AsynchFileData Class

This class provides asynchronous methods to keep tabs on a file.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_AsynchFileData

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_AsynchFileData : IDisposable

The GH_AsynchFileData type exposes the following members.

Constructors
  NameDescription
Public methodGH_AsynchFileData
Asynchronous constructor. File properties will be loaded asychronously.
Top
Properties
  NameDescription
Public propertyCallback
Gets or sets the callback delegate to be used when properties are updated.
Public propertyFileCreated
Gets the date at which the file was created.
Public propertyFileExists
Gets whether the file exists. Note that this property returns false if DataExists=False, regardless of whether the file exists.
Public propertyFileLastChanged
Gets the date at which the file was last changed.
Public propertyFileSize
Gets the size of the file.
Public propertyFileThumbnail
Gets the thumbnail bitmap associated with the file.
Public propertyHarvestThumbnail
Gets or sets whether the thumbnail ought to be parsed. At the moment this only makes sense for GH/GHX files.
Public propertyIsFileData
Gets whether the data has been retrieved at least once.
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the GH_AsynchFileData
Public methodUpdateProperties
Updates all file properties on the thread on which this method is called.
Top
Fields
  NameDescription
Public fieldFilePath
Gets the location this instance is watching.
Public fieldIsLocal
Gets whether Grasshopper thinks the file it is watching is on a local machine.
Top
See Also