Click or drag to resize

GH_ColourPicker Class

Provides the standard Grasshopper Colour picker as a winforms Control.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ColourPicker : UserControl

The GH_ColourPicker type exposes the following members.

Constructors
  NameDescription
Public methodGH_ColourPicker
Initializes a new instance of the GH_ColourPicker class
Top
Properties
  NameDescription
Public propertyAllowNumericInput
Gets or sets whether this colour picker pops up a textbox on channel slider double clicks.
Public propertyColour
Gets or sets the colour currently specified in the picker.
Public propertyDesiredHeight
Gets the ideal height for this control given the current width and UI settings.
Public propertyShowAlphaSlider
Gets or sets whether the alpha channel slider is included.
Public propertyShowChannelSliders
Gets or sets whether the channel sliders are included.
Top
Methods
Events
  NameDescription
Public eventColourChanged
Raised whenever the value of the slider is changed via GUI interaction.
Top
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also