Click or drag to resize

GH_CursorServer Class

Class used to cache and set cursors.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_CursorServer

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_CursorServer

The GH_CursorServer type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of cached cursors.
Top
Methods
  NameDescription
Public methodAttachCursor
Attach a cursor to a control.
Public methodCursor
Gets a cursor from the cache.
Public methodIsCursor
Test for the existence of a cursor.
Public methodReferenceCursors
Reference all the cursor files in a given directory.
Public methodResetCursor
Reset the cursor of the given control to default.
Top
See Also