Click or drag to resize

GH_DigitScroller Class

Provides the standard Grasshopper Digit scroller as a winforms Control.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DigitScroller : GH_TextInputBaseControl

The GH_DigitScroller type exposes the following members.

Constructors
  NameDescription
Public methodGH_DigitScroller
Initializes a new instance of the GH_DigitScroller class
Top
Properties
  NameDescription
Public propertyAllowRadixDrag
Gets or sets whether the radix symbol can be dragged.
Public propertyAllowTextInput
Gets or sets whether the control accepts text input override.
Public propertyAmplify
Gets or sets whether vertical mouse movement ought to be amplified.
Public propertyDecimalPlaces
Gets or sets the number of decimal places.
Public propertyDigitAlign
Gets or sets the digit align mode
Public propertyDigits
Gets or sets the number of digits displayed in the scroller.
Public propertyDigitScroller
Gets the internal scroller object.
Public propertyEpsilon
Gets the smallest possible change with the current settings.
Public propertyMaximumValue
Gets or sets the upper bound of the scroll value.
Public propertyMinimumValue
Gets or sets the lower bound of the scroll value.
Public propertyPrefix
Gets or sets the prefix text
Public propertyRadix
Gets or sets the radix point index.
Public propertySuffix
Gets or sets the prefix text
Public propertyValue
Gets or sets the value of this scroller.
Top
Methods
  NameDescription
Protected methodInput_Assign (Overrides GH_TextInputBaseControl.Input_Assign(String).)
Protected methodInput_Parse (Overrides GH_TextInputBaseControl.Input_Parse(String).)
Protected methodInput_Supply (Overrides GH_TextInputBaseControl.Input_Supply.)
Protected methodOnPaint (Overrides ControlOnPaint(PaintEventArgs).)
Protected methodOnPaintBackground (Overrides ScrollableControlOnPaintBackground(PaintEventArgs).)
Top
Events
  NameDescription
Public eventValueChanged
Top
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also