Click or drag to resize

GH_FontList Class

Represents the installed Font collection. This control allows both navigation and selection of Font Families.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_FontList : GH_DoubleBufferedPanel

The GH_FontList type exposes the following members.

Constructors
  NameDescription
Public methodGH_FontList
Initializes a new instance of the GH_FontList class
Top
Properties
  NameDescription
Public propertyDisplayText
Gets or sets the placeholder string.
Public propertyFilter
Gets or sets the filter string. You must call RecreateFontList() before the new font list is created.
Public propertyFontFamily
Gets or sets the selected font family.
Public propertyFontSize
Gets or sets the font size.
Public propertyFontStyle
Gets or sets the font style for all families.
Top
Methods
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also