Click or drag to resize

GH_FormShepard Class

A Form shepard is used to herde a bunch of floating forms. Important forms that potentially spout child forms might choose to implement one.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_FormShepard

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_FormShepard

The GH_FormShepard type exposes the following members.

Constructors
  NameDescription
Public methodGH_FormShepard
Create a new form shepard.
Top
Properties
  NameDescription
Public propertySheep
Top
Methods
  NameDescription
Public methodRegisterForm
Add a sheep form to the flock. This form will be affected by the location and size of the main form.
Public methodUnregisterForm
Remove a sheep from the flock.
Top
See Also