Click or drag to resize

GH_GeometricFont Class

Exposes methods for drawing geometric characters.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_GeometricFont

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_GeometricFont

The GH_GeometricFont type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberChar0
Gets the default geometry for '0'. Caller is responsible for disposing the path.
Public propertyStatic memberChar1
Gets the default geometry for '1'. Caller is responsible for disposing the path.
Public propertyStatic memberChar2
Gets the default geometry for '2'. Caller is responsible for disposing the path.
Public propertyStatic memberChar3
Gets the default geometry for '3'. Caller is responsible for disposing the path.
Public propertyStatic memberChar4
Gets the default geometry for '4'. Caller is responsible for disposing the path.
Public propertyStatic memberChar5
Gets the default geometry for '5'. Caller is responsible for disposing the path.
Public propertyStatic memberChar6
Gets the default geometry for '6'. Caller is responsible for disposing the path.
Public propertyStatic memberChar7
Gets the default geometry for '7'. Caller is responsible for disposing the path.
Public propertyStatic memberChar8
Gets the default geometry for '8'. Caller is responsible for disposing the path.
Public propertyStatic memberChar9
Gets the default geometry for '9'. Caller is responsible for disposing the path.
Public propertyStatic memberCharBracketClose
Gets the default geometry for '}'. Caller is responsible for disposing the path.
Public propertyStatic memberCharBracketOpen
Gets the default geometry for '{'. Caller is responsible for disposing the path.
Public propertyStatic memberCharDash
Gets the default geometry for '-'. Caller is responsible for disposing the path.
Public propertyStatic memberCharSemiColon
Gets the default geometry for ';'. Caller is responsible for disposing the path.
Top
Methods
  NameDescription
Public methodStatic memberDraw0
Draw the geometric character '0' at the specified location.
Public methodStatic memberDraw1
Draw the geometric character '1' at the specified location.
Public methodStatic memberDraw2
Draw the geometric character '2' at the specified location.
Public methodStatic memberDraw3
Draw the geometric character '3' at the specified location.
Public methodStatic memberDraw4
Draw the geometric character '4' at the specified location.
Public methodStatic memberDraw5
Draw the geometric character '5' at the specified location.
Public methodStatic memberDraw6
Draw the geometric character '6' at the specified location.
Public methodStatic memberDraw7
Draw the geometric character '7' at the specified location.
Public methodStatic memberDraw8
Draw the geometric character '8' at the specified location.
Public methodStatic memberDraw9
Draw the geometric character '9' at the specified location.
Public methodStatic memberDrawBracketClose
Draw the geometric character '}' at the specified location.
Public methodStatic memberDrawBracketOpen
Draw the geometric character '{' at the specified location.
Public methodStatic memberDrawDash
Draw the geometric character '-' at the specified location.
Public methodStatic memberDrawNumber(Graphics, Int32, Color, PointF)
Draw an integer at the specified location.
Public methodStatic memberDrawNumber(Graphics, Int64, Color, PointF)
Draw an integer at the specified location.
Public methodStatic memberDrawNumber(Graphics, UInt32, Color, PointF)
Draw an integer at the specified location.
Public methodStatic memberDrawNumber(Graphics, UInt64, Color, PointF)
Draw an integer at the specified location.
Public methodStatic memberDrawPath
Draw an entire path string at a specific location.
Public methodStatic memberDrawSemiColon
Draw the geometric character ';' at the specified location.
Top
See Also