Click or drag to resize

GH_IconPicker Class

Provides a standard icon selection interface.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_IconPicker : UserControl

The GH_IconPicker type exposes the following members.

Constructors
  NameDescription
Public methodGH_IconPicker
Initializes a new instance of the GH_IconPicker class
Top
Properties
  NameDescription
Public propertyIcon
Gets or sets the icon to be displayed in this picker.
Public propertyIconChanged
Gets a value indicating whether or not the icon has been changed.
Top
Methods
  NameDescription
Protected methodDispose
Releases the unmanaged resources used by the GH_IconPicker and optionally releases the managed resources
(Overrides ContainerControlDispose(Boolean).)
Top
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also