Click or drag to resize

GH_Interpolation Enumeration

Enumerates the possible animation progression types.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_Interpolation
Members
  Member nameValueDescription
None0 No animation occurs.
NearestNeighbour1 Animation interpolation is either equal to A or B, whichever is closest.
Linear2 Linear interpolation between A and B.
EaseIn3 Interpolation that has a derivative of zero at the start.
EaseOut4 Inteprolation that has a derivative of zero at the end.
EaseInAndOut5 Interpolation that has a derivative of zero at both ends.
See Also