Click or drag to resize

GH_QuickImageEditor Class

Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_QuickImageEditor : Form

The GH_QuickImageEditor type exposes the following members.

Constructors
  NameDescription
Public methodGH_QuickImageEditor
Initializes a new instance of the GH_QuickImageEditor class
Top
Properties
  NameDescription
Public propertyCanvasImage
Gets or sets the canvas image.
Public propertyFrameCrop
Gets or sets the cropping rectangle.
Public propertyFrameFocus
Gets or sets the rectangle of the focus frame.
Public propertyFrameViewport
Gets or sets the rectangle of the viewport frame.
Public propertyViewportImage
Gets or sets the viewport image.
Public propertyViewportName
Gets or sets the viewport name to include. If the name string is null or empty, the active viewport is used.
Top
Methods
  NameDescription
Protected methodDispose
Releases the unmanaged resources used by the GH_QuickImageEditor and optionally releases the managed resources
(Overrides FormDispose(Boolean).)
Top
Extension Methods
See Also