Click or drag to resize

GH_RotationalTuningDataT Class

Utility class for keeping track of rotational mouse events.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_RotationalTuningDataT

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_RotationalTuningData<T>

Type Parameters

T
Basic type for initial conditions.

The GH_RotationalTuningDataT type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyFrame
Gets the frame at the given index.
Public propertyFrameCount
Gets the total number of recorded frames.
Public propertyInitialValue
Gets the initial value.
Public propertyPivot
Gets or sets the rotational pivot. You only need to set this if the pivot changes.
Top
Methods
  NameDescription
Public methodAddFrame
Grow the tuning track by one point and compute the angle.
Public methodTotalAngle
Compute the total angle from the first to the last frame.
Public methodTotalTurns
Compute the total number of full turns from the first to the last frame.
Top
See Also