Click or drag to resize

GH_SettingsCategory Class

Base implementation of IGH_SettingsCategory. Derive from this class and provide an empty constructor to play ball.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_SettingsCategory

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_SettingsCategory : IGH_SettingCategory

The GH_SettingsCategory type exposes the following members.

Constructors
  NameDescription
Protected methodGH_SettingsCategory(String, Bitmap)
Create a new top-level category.
Protected methodGH_SettingsCategory(String, String, Bitmap)
Create a new nested category.
Top
Properties
  NameDescription
Public propertyDescription
Public propertyIcon
Public propertyName
Public propertyParent
Top
See Also