Click or drag to resize

GH_TooltipComponent Class

This component provides Grasshopper tooltip functionality through a winforms Component.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_TooltipComponent : Component

The GH_TooltipComponent type exposes the following members.

Constructors
  NameDescription
Public methodGH_TooltipComponent
Initializes a new instance of the GH_TooltipComponent class
Top
Properties
  NameDescription
Public propertyDelay
Gets or sets the delay (in milliseconds) for this tooltip to appear.
Public propertyEnabled
Gets or sets the Enabled flag.
Public propertyTag
Provides an easy way to store information on this Tooltip.
Public propertyTarget
Gets or sets the control this tooltip is tied to.
Top
Methods
  NameDescription
Public methodHide
Public methodIsTag
Test whether the current Tooltip tag matches the object.
Top
Events
  NameDescription
Public eventPopulateTooltip
This event is raised just prior to the tooltip display.
Top
See Also