Click or drag to resize

GH_TooltipDisplayEventArgs Class

Event arguments used in the Tooltip Component.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.GUIGH_TooltipDisplayEventArgs

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_TooltipDisplayEventArgs : EventArgs

The GH_TooltipDisplayEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyControl
Gets the control for whom the tooltip is about to be displayed.
Public propertyDescription
Gets or sets the description of the tooltip. This field is optional.
Public propertyDiagram
Gets or sets the image that is displayed in the details section of the tooltip. This field is optional, but when it is defined, the Description property is ignored.
Public propertyIcon
Gets or sets the icon that is displayed in the upper left hand corner of the tooltip. This field is optional.
Public propertyPoint
Gets the point in control coordinates for the tooltip locus.
Public propertyRegion
Gets or sets the active region (in control coordinates) for this tooltip. Once a tooltip is shown inside the region, the tooltip will 'stick' to the mouse for as long as the mouse remains within this region. By default the region is set to Rectangle.Empty, which indicates that region tracking is not used for this tooltip.
Public propertyText
Gets or sets the text of the tooltip. If you do not set the Text property, you must set the Title property or the tooltip will not be shown.
Public propertyTitle
Gets or sets the title of the tooltip. If you do not set the Title property, you must set the Text property or the tooltip will not be shown.
Public propertyValid
Gets whether there is currently enough data to display a tooltip.
Top
See Also