Click or drag to resize

GH_TrackerFrame Structure

Represents a single frame in a mouse-tracker history. A frame represents all relevant mouse and keyboard data at a given time.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public struct GH_TrackerFrame

The GH_TrackerFrame type exposes the following members.

Constructors
  NameDescription
Public methodGH_TrackerFrame
Initializes a new instance of the GH_TrackerFrame class
Top
Fields
  NameDescription
Public fieldButtons
The state of the mouse buttons of the frame.
Public fieldKeys
The state of the modifier keys (Contro, Shift and Alt) of the frame.
Public fieldPositionControl
The position (in control coordinates) of the frame.
Public fieldPositionScreen
The position (in screen coordinates) of the frame.
Public fieldTag
Optional Tag object (to be supplied by user).
Public fieldTime
The time at which this frame was recorded.
Top
See Also