Click or drag to resize

GH_VerticalScrollBar Class

Scroll bar control with floating point accuracy.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_VerticalScrollBar : GH_DoubleBufferedPanel

The GH_VerticalScrollBar type exposes the following members.

Constructors
  NameDescription
Public methodGH_VerticalScrollBar
Initializes a new instance of the GH_VerticalScrollBar class
Top
Properties
  NameDescription
Public propertyGrip
Gets the actual dimensions of the scroll bar grip.
Public propertyGripRegion
Gets the grip region for this scroll bar. The Grip Region is the area in which the grip can be found. It is essentially the Client area minus the padding.
Public propertyImpliedVerticalOffset
Gets or sets the offset of the target region as implied by the scroll ratio. If you set this value, the ratio is reverse engineered.
Public propertyScreenHeight
Gets or sets the height of the screen area (the visible area)
Public propertyTargetHeight
Gets or sets the height of the target area (the area being scrolled)
Public propertyTargetRatio
Gets or sets the scroll ration. If the scroll ratio is changed, the OnScrollRatioChanged event will be raised.
Top
Methods
Events
  NameDescription
Public eventScrollRatioChanged
Top
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also