Click or drag to resize

GH_WindowsFormUtil Class

Exposes some static (Shared) utility functions for positioning custom windows.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_WindowsFormUtil

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_WindowsFormUtil

The GH_WindowsFormUtil type exposes the following members.

Methods
  NameDescription
Public methodStatic memberCenterFormOnCursor
Positions a Form so that it is centered around the cursor
Public methodStatic memberCenterFormOnEditor
Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden, the form will be centered on the screen instead.
Public methodStatic memberCenterFormOnScreen
Positions a Form so that it is centered on the current screen. The current screen being defined as the screen containing the cursor.
Public methodStatic memberCenterFormOnWindow
Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden, the form will be centered on the screen instead.
Top
See Also