Click or drag to resize

GH_Grip Class

Represents a grip in a gradient. A grip defines both where and how the colour of a gradient changes.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.GradientGH_Grip

Namespace:  Grasshopper.GUI.Gradient
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Grip : IComparable<GH_Grip>, 
	GH_ISerializable

The GH_Grip type exposes the following members.

Constructors
  NameDescription
Public methodGH_Grip
Initializes a new instance of the GH_Grip class
Public methodGH_Grip(GH_Grip)
Initializes a new instance of the GH_Grip class
Public methodGH_Grip(Double, Color)
Initializes a new instance of the GH_Grip class
Public methodGH_Grip(Double, Color, Color)
Initializes a new instance of the GH_Grip class
Top
Properties
  NameDescription
Public propertyColourLeft
Gets the colour to the left of this grip.
Public propertyColourRight
Gets the colour to the right of this grip.
Public propertyGripId
Gets the Grip ID.
Public propertyIsValid
Gets whether this grip is valid. A valid grip must have a non-empty Id and a non-NaN parameter.
Public propertyParameter
Gets or sets the numeric parameter of the grip.
Public propertySelected
Gets or sets whether this grip is selected. Selection state is not (de)serialized.
Public propertyType
Gets whether the colour across this grip is smooth.
Top
Methods
  NameDescription
Public methodStatic memberBlend
Public methodCompareTo
Public methodMutateId
Create a new grip ID.
Public methodRead
Public methodWrite
Top
See Also