Click or drag to resize

IGH_SettingCategory Interface

Represents a single category in the Settings UI. Implement this interface or derive from GH_SettingsCategory to add a new Category to the Grasshopper Settings interface.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_SettingCategory

The IGH_SettingCategory type exposes the following members.

Properties
  NameDescription
Public propertyDescription
Category description.
Public propertyIcon
Category icon. Image should be 48x48 pixels.
Public propertyName
Category name (not case sensitive). Use dots to separate subcategories.
Public propertyParent
Gets the name of the parent category. If the category is supposed to be top-level, this property will return null or a String.Empty.
Top
See Also