Click or drag to resize

GH_PageSettings Class

Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.ThemeGH_PageSettings

Namespace:  Grasshopper.GUI.Theme
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PageSettings

The GH_PageSettings type exposes the following members.

Properties
  NameDescription
Public propertyDrawGrid
Gets or sets whether the grid ought to be drawn.
Public propertyDrawPage
Gets or sets whether the page ought to be drawn.
Public propertyDrawShadow
Gets or sets whether the page shadow ought to be drawn. If the page is not drawn, neither is the page shadow, irregardless of this property.
Public propertyEdgeColour
Gets or sets the page edge colour to be used.
Public propertyFillColour
Gets or sets the page fill colour to be used.
Public propertyGridColour
Gets or sets the page grid colour to be used.
Public propertyGridHeight
Gets or sets the height of a page grid cell.
Public propertyGridPattern
Gets or sets the dash pattern to apply to grid lines. Leave null or empty for a solid line.
Public propertyGridWidth
Gets or sets the width of a page grid cell.
Public propertyShadowColour
Gets or set the page shadow colour to be used.
Public propertyShadowSize
Gets or sets the size of the page shadow.
Top
See Also