Click or drag to resize

GH_IndexRange Structure

Represents a range of indices.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public struct GH_IndexRange : GH_ISerializable

The GH_IndexRange type exposes the following members.

Constructors
  NameDescription
Public methodGH_IndexRange(Int32)
Create a new singular range.
Public methodGH_IndexRange(Int32, Int32)
Create a new range.
Top
Properties
  NameDescription
Public propertyIndex0
Gets the first index in the range.
Public propertyIndex1
Gets the last index in the range.
Public propertyStatic memberInvalidRange
Gets the predefined invalid range.
Public propertyIsSingular
Gets whether the range has zero length.
Public propertyIsValid
Gets whether this range is valid.
Public propertyLength
Gets the length of the range.
Public propertyStatic memberMaxValue
Top
Methods
  NameDescription
Public methodAdjacentTo
Tests whether this range is adjacent to another.
Public methodContains(GH_IndexRange)
Tests whether a specified range is entirely contained within this range.
Public methodContains(Int32)
Tests whether a specified index is defined by this range.
Public methodStatic memberIntersection
Create the intersection between two ranges.
Public methodIntersectsWith
Tests whether certain indices are described by both this and another range.
Public methodStatic memberSplit
Split a range into two using an integer index.
Public methodToString (Overrides ValueTypeToString.)
Public methodStatic memberUnion
Create a range which contains both input ranges.
Top
See Also