Click or drag to resize

GH_ExpressionParser Class

Provides a run-time evaluator for Grasshopper expressions.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.ExpressionsGH_ExpressionParser

Namespace:  Grasshopper.Kernel.Expressions
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ExpressionParser

The GH_ExpressionParser type exposes the following members.

Constructors
  NameDescription
Public methodGH_ExpressionParser
Initializes a new instance of the GH_ExpressionParser class
Public methodGH_ExpressionParser(Boolean)
Initializes a new instance of the GH_ExpressionParser class
Top
Properties
  NameDescription
Public propertyThrowExceptions
Public propertyVariables
Top
Methods
  NameDescription
Public methodAddVariable(String, Complex)
Public methodAddVariable(String, Plane)
Public methodAddVariable(String, Point3d)
Public methodAddVariable(String, Vector3d)
Public methodAddVariable(String, Boolean)
Public methodAddVariable(String, Double)
Public methodAddVariable(String, Int32)
Public methodAddVariable(String, String)
Public methodAddVariableEx(String, GH_Variant)
Public methodAddVariableEx(String, IGH_Goo)
Public methodStatic memberBalancedCharTest
Test a string for balanced open and close chars. You can use this function to see if brackets or parenthesis have been properly used.
Public methodCachedSymbols
Retrieve a copy of the Queue of cached symbols. You can use the cached symbols as an uber-optimization to speed up successive calls to Evaluate() with an identical expression string
Public methodCacheSymbols
Create a Symbols array from the expression. Use this method if you intend to evaluate the same expression multiple times. At this point, the expression has to be in correct syntax format. Use the GH_ExpressionSyntaxWriter.RewriteAll() method to make sure.
Public methodClearSymbols
Destroy the Symbols cache.
Public methodClearVariables
Destroy the variable cache.
Public methodDisplayFunctionList
Public methodEvaluate
Evaluate the expression currently loaded in the Symbols cache using the currently loaded variables.
Public methodEvaluate(QueueGH_ParserSymbol)
Evaluate the expression queue without overriding any local caches. You can obtain an expression queue by calling CachedSymbols()
Public methodEvaluate(String)
Store a new expression in the Symbols cache and evaluate it using the current variables
Public methodStatic memberIsValidVariableName
Tests whether a string is a valid variable name for expressions. Valid names must contain at least one character, must start with an alphabetic character, and only contain alphanumeric chars and underscores.
Protected methodOp_BinaryAddition
Protected methodOp_BinaryAmpersand
Protected methodOp_BinaryAND
Protected methodOp_BinaryAngle
Protected methodOp_BinaryCircumflex
Protected methodOp_BinaryCrossProduct
Protected methodOp_BinaryDistance
Protected methodOp_BinaryDivision
Protected methodOp_BinaryEquality
Protected methodOp_BinaryIntegerDivision
Protected methodOp_BinaryLargerThan
Protected methodOp_BinaryLargerThanOrEqual
Protected methodOp_BinaryModulus
Protected methodOp_BinaryMultiplication
Protected methodOp_BinaryNearEquality
Protected methodOp_BinaryOR
Protected methodOp_BinaryPull
Protected methodOp_BinaryPush
Protected methodOp_BinarySmallerThan
Protected methodOp_BinarySmallerThanOrEqual
Protected methodOp_BinarySubtraction
Protected methodOp_BinaryXOR
Protected methodOp_UnaryBang
Protected methodOp_UnaryCube
Protected methodOp_UnaryDeg2Rad
Protected methodOp_UnaryImaginary
Protected methodOp_UnaryMinus
Protected methodOp_UnaryNOT
Protected methodOp_UnaryOComponent
Protected methodOp_UnaryPlus
Protected methodOp_UnarySquare
Protected methodOp_UnaryXComponent
Protected methodOp_UnaryYComponent
Protected methodOp_UnaryZComponent
Top
See Also