Click or drag to resize

GH_Component Class

Inherit from this class if you wish to create a custom component. Note that you must provide a public, empty constructor which calls the base class constructor.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_Component : GH_ActiveObject, 
	IGH_Component, IGH_RenderAwareObject

The GH_Component type exposes the following members.

Properties
  NameDescription
Public propertyClippingBox
Gets the clipping box for all preview geometry drawn by this component and all associated parameters.
Protected propertyHelpDescription
Override this method if you want the help topic content to be more than the Component description.
Public propertyHidden
Gets or sets the hidden flag for this component. Does not affect Hidden flags on parameters associated with this component.
Public propertyInConstructor
Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.
Public propertyInstanceDescription (Overrides GH_InstanceDescriptionInstanceDescription.)
Public propertyIsBakeCapable
Public propertyIsDataProvider
Components are never Data providers. Only the output parameters can be considered to be providers.
(Overrides GH_ActiveObjectIsDataProvider.)
Public propertyIsPreviewCapable
If a single parameter is PreviewCapable, so is the component. Override this property if you need special Preview flags.
Public propertyIsValidPrincipalParameterIndex
Gets whether the MasterParameterIndex property identifies a valid parameter.
Public propertyLocked
Gets or sets the Locked state for this Component. This also sets locked states for all input and output parameters.
(Overrides GH_ActiveObjectLocked.)
Public propertyMessage
Gets or sets a custom message to be displayed underneath the component. This message is not serialized and should be assigned on every solution anew.
Public propertyParams
Gets the parameter manager object for this component.
Public propertyPrincipalParameterIndex
Gets or sets the principal parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular principal parameter detection will kick in.
Public propertyProcessorTime
Gets the total processor time (profiler) spend by this component and all input parameters.
(Overrides GH_ActiveObjectProcessorTime.)
Public propertyRunCount
Gets a value indicating how many times the SolveInstance method was called on this component during the last solution. This property will return -1 if no valid runcount is available.
Public propertyRuntimeMessageLevel
Returns the worst case runtime warning level of me and all my parameters
(Overrides GH_ActiveObjectRuntimeMessageLevel.)
Top
Methods
  NameDescription
Public methodAddedToDocument
Overrides the AddedToDocument method and delegates the call to all parameters.
(Overrides GH_DocumentObjectAddedToDocument(GH_Document).)
Protected methodAfterSolveInstance
Override this method if you want to be called after the last call to SolveInstance.
Protected methodAppendAdditionalComponentMenuItems
Override this function if you want to insert some custom menu items in your derived Component class. Items will be added between List Matching items and parameter menus.
Public methodAppendAdditionalMenuItems
Adds typical component type items to the context menu: 1. Data comparison types 2. Custom (overridden) items 3. Nested input parameter context menu items 4. Nested output parameter context menu items
(Overrides GH_ActiveObjectAppendAdditionalMenuItems(ToolStripDropDown).)
Protected methodAssignInitCodeToInputParameter
Utility function for parsing and assigning init codes. This only works for standard parameter types.
Public methodBakeGeometry(RhinoDoc, ListGuid)
Public methodBakeGeometry(RhinoDoc, ObjectAttributes, ListGuid)
Protected methodBeforeSolveInstance
Override this method if you want to be called before the first call to SolveInstance.
Public methodClearData
Clear the data inside this component and all output parameters.
(Overrides GH_ActiveObjectClearData.)
Public methodClearRuntimeMessages
Clears all runtime messages in me and my parameters
(Overrides GH_ActiveObjectClearRuntimeMessages.)
Public methodCollectData
Calls CollectData on all input parameters and makes sure the Component and all associated parameters are left in a valid state.
(Overrides GH_ActiveObjectCollectData.)
Public methodComputeData
Compute all data and fill out all output parameters.
(Overrides GH_ActiveObjectComputeData.)
Public methodCreateAttributes
Create new attributes.
(Overrides GH_DocumentObjectCreateAttributes.)
Public methodDependsOn
Returns True is any one of my input parameters depends on the source.
(Overrides GH_ActiveObjectDependsOn(IGH_ActiveObject).)
Protected methodStatic memberDocumentAngleTolerance
Gets the Angle tolerance (in radians) for the currently active Rhino document.
Public methodDocumentContextChanged
Overrides the DocumentContextChanged method and delegates the call to all parameters.
(Overrides GH_DocumentObjectDocumentContextChanged(GH_Document, GH_DocumentContext).)
Protected methodStatic memberDocumentTolerance
Gets the Absolute tolerance for the currently active Rhino document.
Public methodDrawViewportMeshes
Draw preview meshes for this component and all associated parameters.
Public methodDrawViewportWires
Draw preview wires for this component and all associated parameters.
Protected methodExpireDownStreamObjects
Expire all objects that depend on any of the output parameters.
(Overrides GH_ActiveObjectExpireDownStreamObjects.)
Protected methodGenerateDefaultHTML
Creates the default component help topic, including all parameter lists.
Protected methodGenerateParameterHelp
Create an HTML string that lists names and descriptions for input and output parameters.
Protected methodGenerateParameterHelp(IGH_Param)
Generate HTML string for a single parameter.
Protected methodHtmlHelp_Source
Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com
(Overrides GH_DocumentObjectHtmlHelp_Source.)
Public methodIsolateObject
Sever the connections of all input and output parameters.
(Overrides GH_DocumentObjectIsolateObject.)
Public methodMovedBetweenDocuments
Overrides the MovedBetweenDocuments method and delegates the call to all parameters.
(Overrides GH_DocumentObjectMovedBetweenDocuments(GH_Document, GH_Document).)
Protected methodPostConstructor
The PostConstructor is called from within each constructor. DO NOT OVERRIDE THIS unless you know what you are doing.
Public methodRead
Read all required data for deserialization from an IO archive.
(Overrides GH_ActiveObjectRead(GH_IReader).)
Protected methodRegisterInputParams
Declare all your input parameters here.
Protected methodRegisterOutputParams
Declare all your output parameters here.
Public methodRegisterRemoteIDs
Registers all my input parameters with the UUID_LookUpTable
(Overrides GH_ActiveObjectRegisterRemoteIDs(GH_GuidTable).)
Public methodRemovedFromDocument
Overrides the RemovedFromDocument method and delegates the call to all parameters.
(Overrides GH_DocumentObjectRemovedFromDocument(GH_Document).)
Public methodRuntimeMessages
Gets the list of cached runtime messages that were recorded during solver-time processes. For components, the set of runtime messages also includes input and output parameters.
(Overrides GH_ActiveObjectRuntimeMessages(GH_RuntimeMessageLevel).)
Protected methodSolveInstance
This function will be called (successively) from within the ComputeData method of this component.
Public methodWrite
Write all required data for deserialization to an IO archive.
(Overrides GH_ActiveObjectWrite(GH_IWriter).)
Top
Events
  NameDescription
Top
Fields
  NameDescription
Top
See Also