Click or drag to resize

GH_DocUndoEventArgs Class

These arguments are passed along with UndoStateChanged events on GH_Document.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_DocUndoEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocUndoEventArgs : EventArgs

The GH_DocUndoEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyDocument
Gets the document that raised the event.
Public propertyOperation
Gets the type of undo operation that caused this event.
Public propertyRecord
Gets the UndoRecord pertaining to this event. Not every Event type has a single record associated with it so be sure to test for null.
Top
See Also