Click or drag to resize

GH_GHALoadingEventArgs Class

Event arguments used in the GH_GHALoaded event on GH_ComponentServer.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_GHALoadingEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_GHALoadingEventArgs : EventArgs

The GH_GHALoadingEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyAssembly
Gets the assembly that was loaded from the GHA file.
Public propertyFileName
Gets the location of the gha file.
Public propertyIcon
Gets the official icon of the GHA file.
Public propertyId
Gets the Id of the GHA file.
Public propertyLoadingMechanism
Gets the mechanism that was used to load the file.
Public propertyName
Gets the official name of the GHA file.
Top
See Also