Click or drag to resize

GH_MatchLevel Enumeration

All possible string matching schemes.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
[FlagsAttribute]
public enum GH_MatchLevel
Members
  Member nameValueDescription
None0 No match is performed.
Exact1 String must match the key exactly.
Start2 String must start with the key.
WordExact4 String must contain word that is an exact match with the key.
WordStart8 String must contain a word that starts with the key.
Contains16 String must contain the key.
Fuzzy32 String must contain word that is somewhat similar to the key.
AllClean31 Represents all match types except fuzzy matching.
All63 Represents all match types.
See Also