Click or drag to resize

GH_ObjectChangedEventArgs Class

Event arguments passed during ObjectChanged events.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_ObjectChangedEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ObjectChangedEventArgs : EventArgs

The GH_ObjectChangedEventArgs type exposes the following members.

Constructors
  NameDescription
Public methodGH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType)
Initializes a new instance of the GH_ObjectChangedEventArgs class
Public methodGH_ObjectChangedEventArgs(IGH_DocumentObject, String)
Initializes a new instance of the GH_ObjectChangedEventArgs class
Public methodGH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType, Object)
Initializes a new instance of the GH_ObjectChangedEventArgs class
Public methodGH_ObjectChangedEventArgs(IGH_DocumentObject, String, Object)
Initializes a new instance of the GH_ObjectChangedEventArgs class
Top
Properties
  NameDescription
Public propertyCustomType
Gets the customised type description of this event. This field is only set when the Type is GH_ObjectEventType.Custom.
Public propertySender
Gets the object which raised this event.
Public propertyTag
Gets the tag for this event.
Public propertyType
Gets the type of this event.
Top
Fields
See Also