Click or drag to resize

GH_RuntimeMessage Class

Contains all fields that together define a RuntimeMessage. Runtime Messages are created and recorded by document objects during Grasshopper solutions.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_RuntimeMessage

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_RuntimeMessage

The GH_RuntimeMessage type exposes the following members.

Constructors
  NameDescription
Public methodGH_RuntimeMessage
Initializes a new instance of the GH_RuntimeMessage class
Top
Properties
  NameDescription
Public propertyEvent
Gets the time at which the message was recorded.
Public propertyHasSource
Gets a value indicating whether or not this message has a source.
Public propertyMessage
Gets the contents of the message.
Public propertySource
Gets a string describing the source object that created the message.
Public propertyType
Gets the type qualifier of the message.
Top
See Also