Click or drag to resize

GH_StateServer Class

Maintains all the recorded states for this document.
Inheritance Hierarchy
SystemObject
  System.Collections.GenericListGH_State
    Grasshopper.KernelGH_StateServer

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_StateServer : List<GH_State>, 
	GH_ISerializable

The GH_StateServer type exposes the following members.

Constructors
  NameDescription
Public methodGH_StateServer
Initializes a new instance of the GH_StateServer class
Top
Properties
  NameDescription
Public propertyNames
Gets a list of all the state names in this server.
Public propertyOwner
Gets the document that owns this server.
Top
Methods
  NameDescription
Public methodNewStateFromDocument
Displays UI for new state creation. If the user aborts, then null is returned. If the user successfully defines a new state, it is appended to this server.
Public methodRead
Public methodRemoveState
Remove a certain state. This method adds an undo record to the document.
Public methodRestoreState(Int32, Int32, Int32)
Restore a certain state.
Public methodRestoreState(String, Int32, Int32)
Restore a certain state.
Public methodRestoreState(Int32, Boolean, Int32, Int32)
Restore a certain state.
Public methodWrite
Top
See Also