Click or drag to resize

Node3dT Class

Basic node in a Tree3d structure. Nodes in tree structures maintain a local region and either a list of content indices or a list of up to 8 child nodes.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.Geometry.SpatialTreesNode3dT

Namespace:  Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class Node3d<T>

Type Parameters

T

The Node3dT type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyCenter
Gets the center of the spatial region of this node. If the node contains no children the center is always in the middle of the Region. If the node does contain child-nodes, the center may be anywhere within the region.
Public propertyChildCount
Gets the number of defined child nodes. Leaf nodes have no children. Root and twig nodes can have anywhere between 1 and 8 children.
Public propertyChildNode
Gets the child node at the given index.
Public propertyContentAverage
Returns the average coordinate of all items in this node. If this node does not contain any items, Point3d.Unset is returned.
Public propertyContentBoundingBox
Returns the boundingbox of all items in this node. If this node does not contain any items, BoundingBox.Empty is returned.
Public propertyIndicesLocal
Gets the list of item indices that are contained within this node.
Public propertyIndicesRecursive
Gets the list of item indices that are contained within this node and any child nodes.
Public propertyIsLeaf
Gets whether this node is a leaf node. Leaf nodes have no child nodes.
Public propertyIsMutable
Gets whether this tree is mutable. You can only add items to mutable trees. We don't recommend removing items from unmutable trees, though that shouldn't necessarily lead to problems. Trees become unmutable after a call to ShrinkRegions(), CollapseNodes() or OptimizeTree().
Public propertyIsRoot
Gets whether this node is a root node. Root nodes have no parent node and depth zero.
Public propertyIsTwig
Gets whether this node is a twig node. Twig nodes have both parents and at least one child.
Public propertyItemCount
Gets the total number of items stored directly in this node.
Public propertyItemsGlobal
Gets the list of all items stored inside this entire tree. Do not modify this collection unless you know what you are doing.
Public propertyItemsLocal
Gets a list of all the items stored directly in this node. This list is constructed every time you access this property, so keep it down to a minimum.
Public propertyLimit
Gets the subdivision limit for this tree. This limit can only be set once when you create a new tree. It is fixed forever after.
Public propertyMemoryConsumption
Gets the estimated memory consumption of the (sub)tree structure. Items inside the global list are not included in this estimate.
Public propertyNextNode
Gets the logical neighbour to the right of this node. There is no spatial relationships between logical neighbours, this is purely an iteration aid.
Public propertyNodeDepth
Gets the recursive depth of this node. The tree root is at depth zero. The first subdivision is at depth one, and so on and so forth.
Public propertyParentNode
Gets the immediate parent of this node. Root nodes have no parent.
Public propertyRegion
Gets the spatial region of this node.
Public propertyRootNode
Gets the ultimate root node for this tree.
Public propertyWeightedSubdivision
Gets or sets whether subdivision is weighted based on content averages. Setting this value will only affect future subdivisions, not existing ones.
Top
Methods
  NameDescription
Public methodAdd
Insert another item into the tree. The item should be within the region of this node.
Public methodAddRange
Insert a collection of items into the tree. The items should all be within the region of this node.
Public methodAddToRhinoDocument
Public methodCollapseNodes
Collapse the (sub)tree rooted at this node. Collapsing happens when a node only has a single child, in which case the child usurps the position previously held by the parent. Do not collapse a (sub)tree if you still plan to add items later.
Public methodFurthestItem(T)
Find the furtest item.
Public methodFurthestItem(Point3d)
Find the furtest item.
Public methodFurthestItem(Double, Double, Double)
Find the furtest item.
Public methodFurthestItem(T, Double, Double)
Find the furtest item.
Public methodFurthestItem(Point3d, Double, Double)
Find the furtest item.
Public methodFurthestItem(Double, Double, Double, Double, Double)
Find the furtest item.
Public methodNearestItem(T)
Find the nearest item.
Public methodNearestItem(Point3d)
Find the nearest item.
Public methodNearestItem(Double, Double, Double)
Find the nearest item.
Public methodNearestItem(T, Double, Double)
Find the nearest item.
Public methodNearestItem(Point3d, Double, Double)
Find the nearest item.
Public methodNearestItem(Double, Double, Double, Validation3dT)
Find the nearest item using custom validation criteria.
Public methodNearestItem(Double, Double, Double, Double, Double)
Find the nearest item.
Public methodNearestItems(T, Int32)
Find the N nearest items.
Public methodNearestItems(Double, Double, Double, Int32)
Find the N nearest items.
Public methodNearestItems(T, Int32, Double, Double)
Find the N nearest items.
Public methodNearestItems(Double, Double, Double, Int32, Double, Double)
Find the N nearest items.
Public methodOptimizeTree
Optimize this tree for fast searches. Do not call this method if you still plan to add items in the future. You can no longer modify this tree once it has been optimized.
Public methodRemove(Index3dT)
Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public methodRemove(Int32)
Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public methodShrinkRegions
Shrink the region for this node and all child nodes. Do not use this method if you intend to add more items later as it creates spatial gaps in the tree structure. You can shrink nodes if you're done adding items and want to start searching the tree.
Public methodSubTree
Gets an iterator for all nodes in this (sub)tree.
Public methodTrimExcess
Trim the excess space on all index lists. You can call this method to reduce memory usage. It will not modify the tree in any functional way.
Top
See Also