Click or drag to resize

IGH_ActiveObject Interface

Base interface for all objects on the canvas that participate in solutions

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_ActiveObject : IGH_DocumentObject

The IGH_ActiveObject type exposes the following members.

Properties
  NameDescription
Public propertyIsDataProvider
Gets whether or not this object is capable of emitting data.
Public propertyLocked
Gets or sets the locked flag of this object. Locked objects are ignored during solutions.
Public propertyMutableNickName
Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.
Public propertyPhase
Gets the solution phase in which this object is currently stuck.
Public propertyProcessorTime
Gets the most recent measured processor time.
Public propertyRuntimeMessageLevel
Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error.
Top
Methods
  NameDescription
Public methodAddRuntimeMessage
Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.
Public methodClearData
This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank
Public methodClearRuntimeMessages
Clear all message lists.
Public methodCollectData
This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected
Public methodComputeData
This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed.
Public methodDependsOn
Solve the inheritance relationship between this object and a potential parental object.
Public methodRegisterRemoteIDs
If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling.
Public methodRuntimeMessages
Gets the list of cached runtime messages that were recorded during solver-time processes.
Public methodSDKCompliancy
Test whether this object is compliant with a given Rhino version.
Top
Events
  NameDescription
Top
See Also