Click or drag to resize

IGH_StateTag Interface

A StateTag is a visual feedback mechanism that reflects a certain local setting of an Object.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_StateTag

The IGH_StateTag type exposes the following members.

Properties
  NameDescription
Public propertyDescription
Gets the description of this state tag.
Public propertyIcon
Gets the 16 by 16 pixel icon associated with this state tag.
Public propertyName
Gets the name field of this state tag.
Public propertyStage
Gets or sets the Stage rectangle for this state tag. Stages are assigned during Attribute Layout operations by owner objects.
Public propertyStateDescription
Gets or sets the state description of this tag. The state description appears in the Tooltip info field.
Top
Methods
  NameDescription
Public methodRender
Render this tag into a graphics surface.
Top
See Also