Click or drag to resize

IGH_UpgradeObject Interface

Create a class with an empty constructor that implements this interface if you want to provide an upgrade mechanism.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_UpgradeObject

The IGH_UpgradeObject type exposes the following members.

Properties
  NameDescription
Public propertyUpgradeFrom
Gets the ComponentGuid of the old object (the object to be updated).
Public propertyUpgradeTo
Gets the ComponentGuid of the new object (the object that will be inserted).
Public propertyVersion
Return a DateTime object that indicates when this upgrade mechanism was written, so that it becomes possible to distinguish competing upgrade mechanisms.
Top
Methods
  NameDescription
Public methodUpgrade
Upgrade an existing object.
Top
See Also