Click or drag to resize

GH_GeometricGooT Class

Abstract base implementation of IGH_GeometricGoo. If you implement IGH_GeometricGoo, use this for a booster.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooT
    Grasshopper.Kernel.TypesGH_GeometricGooT
      More...

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_GeometricGoo<T> : GH_Goo<T>, 
	IGH_GeometricGoo

Type Parameters

T

The GH_GeometricGooT type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyBoundingbox
Gets the boundingbox for this geometry.
Public propertyIsGeometryLoaded
Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public propertyIsReferencedGeometry
Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public propertyIsValid
Gets a value indicating whether or not the current value is valid.
(Overrides GH_GooTIsValid.)
Public propertyReferenceID
Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty.
Public propertyValue
Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future.
(Overrides GH_GooTValue.)
Top
Methods
  NameDescription
Public methodCastFrom
Attempt a cast from generic object.
(Overrides GH_GooTCastFrom(Object).)
Public methodCastToQ(Q)
Attempt a cast to type T.
(Overrides GH_GooTCastToQ(Q).)
Public methodClearCaches
Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value.
Public methodDuplicate
Make a complete duplicate of this instance. No shallow copies.
(Overrides GH_GooTDuplicate.)
Public methodDuplicateGeometry
Make a complete duplicate of this geometry. No shallow copies.
Public methodEmitProxy
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Overrides GH_GooTEmitProxy.)
Public methodGetBoundingBox
Compute an aligned boundingbox.
Public methodLoadGeometry
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public methodLoadGeometry(RhinoDoc)
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public methodMorph
Morph the object or a deformable representation of the object.
Public methodTransform
Transforms the object or a deformable representation of the object.
Top
Fields
See Also
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooT
    Grasshopper.Kernel.TypesGH_GeometricGooT
      Grasshopper.Kernel.TypesGH_Arc
      Grasshopper.Kernel.TypesGH_Box
      Grasshopper.Kernel.TypesGH_Brep
      Grasshopper.Kernel.TypesGH_Circle
      Grasshopper.Kernel.TypesGH_Curve
      Grasshopper.Kernel.TypesGH_Line
      Grasshopper.Kernel.TypesGH_Mesh
      Grasshopper.Kernel.TypesGH_Plane
      Grasshopper.Kernel.TypesGH_Rectangle
      Grasshopper.Kernel.TypesGH_SubD
      Grasshopper.Kernel.TypesGH_Surface