Click or drag to resize

GH_Interval Class

Represents a one-dimensional numeric domain.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooInterval
    Grasshopper.Kernel.TypesGH_Interval

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Interval : GH_Goo<Interval>

The GH_Interval type exposes the following members.

Constructors
  NameDescription
Public methodGH_Interval
Default constructor
Public methodGH_Interval(GH_Interval)
Create a duplicate from another interval.
Public methodGH_Interval(Interval)
Create a duplicate of another interval
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance. Intervals are invalid if either of the extremes is a #NaN.
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate
Create a duplicate of this interval.
(Overrides GH_GooTDuplicate.)
Public methodDuplicateInterval
Create a duplicate of this interval.
Public methodEmitProxy
Returns a proxy that represents this interval. Do not call this function unless you're
(Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString
Format the interval using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also