Click or drag to resize

GH_Plane Class

Represents a 3D plane. GH_Plane re-implements the OpenNURBS OnPlane class.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooPlane
    Grasshopper.Kernel.TypesGH_GeometricGooPlane
      Grasshopper.Kernel.TypesGH_Plane

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Plane : GH_GeometricGoo<Plane>, 
	IGH_BakeAwareData, IGH_PreviewData

The GH_Plane type exposes the following members.

Constructors
  NameDescription
Public methodGH_Plane
Default constructor. Creates a world XY plane.
Public methodGH_Plane(GH_Plane)
Create a duplicate of another plane.
Public methodGH_Plane(Guid)
Initializes a new instance of the GH_Plane class
Public methodGH_Plane(Plane)
Create a duplicate of another plane.
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsValid
Gets the validity of the plane. If the plane is invalid, attempts are made to fix the data. If the plane remains invalid, False is returned.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodStatic memberDrawPlane(DisplayPipeline, Plane)
Draw a plane with default colours and default size.
Public methodStatic memberDrawPlane(DisplayPipeline, Plane, Double, Int32)
Public methodStatic memberDrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color)
Public methodStatic memberDrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color, Color)
Public methodStatic memberDrawPlaneIcon
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this plane.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicatePlane
Create a duplicate of this plane.
Public methodEmitProxy
Returns a proxy that represents this plane. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc) (Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString
Format the plane using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also