Click or drag to resize

GH_Point Class

Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_Point

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Point : IGH_GeometricGoo, IGH_BakeAwareData, 
	IGH_PreviewData

The GH_Point type exposes the following members.

Constructors
  NameDescription
Public methodGH_Point
Initializes a new instance of the GH_Point class
Public methodGH_Point(GH_Point)
Initializes a new instance of the GH_Point class
Public methodGH_Point(Guid)
Initializes a new instance of the GH_Point class
Public methodGH_Point(Point3d)
Initializes a new instance of the GH_Point class
Top
Properties
  NameDescription
Public propertyBoundingbox
Public propertyClippingBox
Public propertyIsGeometryLoaded
Public propertyIsReferencedGeometry
Public propertyIsValid
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public propertyReferenceData
Gets or sets the reference data of this point geometry.
Public propertyReferenceID
Public propertyTypeDescription
Public propertyTypeName
Public propertyValue
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Public methodCastToT
Public methodClearCaches
Public methodCreateFromCoordinate
Create a new point geometry instance based on a fixed coordinate
Public methodCreateFromCurveDistance
Create new point geometry instance based on a curve distance parameter
Public methodCreateFromCurveRatio
Create new point geometry instance based on a curve parameter ratio
Public methodCreateFromEdgeDistance
Create new point geometry instance based on a curve distance parameter
Public methodCreateFromEdgeRatio
Create new point geometry instance based on an edge parameter ratio
Public methodCreateFromPointObject
Create a new point geometry instance based on point object ID. Technically this now also accepts Dot object IDs.
Public methodCreateFromSurfaceParam
Create new point geometry instance based on a curve distance parameter
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate
Public methodDuplicateGeometry
Public methodDuplicatePoint
Public methodEmitProxy
Public methodEnsureReferenceData
Creates new Reference data if it doesn't already exists
Public methodGetBoundingBox
Public methodLoadGeometry
Public methodLoadGeometry(RhinoDoc)
Public methodMorph
Public methodRead
Public methodReferenceCurve
Public methodReferenceCurve(RhinoObject)
Public methodReferenceIndex
Retrieve the index of the point reference data.
Public methodReferenceIndex(Int32)
Sets the index of the point reference data.
Public methodReferenceParam(Int32)
Retrieve the indexed param of the point reference data.
Public methodReferenceParam(Int32, Double)
Sets the index of the point reference data.
Public methodReferencesCurve
Returns true if this point is based on a curve reference
Public methodReferencesEdge
Returns True if this point is based on an edge reference
Public methodReferenceSurface
Public methodReferenceType
Retrieve the reference type of this point object.
Public methodReferenceType(GH_PointRefType)
Sets the type of the point reference data.
Public methodScriptVariable
Public methodSetReferenceParams
Sets both param values of the point reference
Public methodShowReferenceDialog
Public methodShowReferenceDialog(IWin32Window)
Public methodToString (Overrides ObjectToString.)
Public methodTransform
Public methodWrite
Top
See Also